New Posts New Posts RSS Feed - not receiving HP_EVENT_ASYNC_PLAYBACK_DONE
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Way2call telephony device is your ultimate telephony integration solution!


 Post Reply Post Reply
doronsh View Drop Down

Joined: Mar 16 2009
Status: Offline
Points: 95
Post Options Post Options   Thanks (0) Thanks(0)   Quote doronsh Quote  Post ReplyReply Direct Link To This Post Topic: not receiving HP_EVENT_ASYNC_PLAYBACK_DONE
    Posted: Sep 10 2009 at 7:50pm
Hi Gordon,
The 'Playback Done' event is triggered (internally in the Hi-Phone DLL) via
a window message.

The solution is to 'pump messages' .
Note: the 'pumping' thread must be the same thread that called

We"ll put a note on it in the SDK.

I would appreciate if you can send me a feedback if it works.

Best Regards,
Back to Top
gymshoe View Drop Down

Joined: Mar 15 2009
Status: Offline
Points: 4
Post Options Post Options   Thanks (0) Thanks(0)   Quote gymshoe Quote  Post ReplyReply Direct Link To This Post Posted: Apr 13 2009 at 9:55pm
Hi,  I am using the w2cUsbM_PlayWaveFile() method and everything was working fine.  I recently upgraded to W2cMdSDK20090408 and now I do not seem to see the HP_EVENT_ASYNC_PLAYBACK_DONE event after the audio file plays.   I am playing the standard c:\windows\media\tada.wav file which is fairly short, I have also tried longer wav files.   I am using a headset and I can hear the wav file play properly. My code performs as little processing as possible when an event is delivered, it just places the event on a queue and returns so as to not tie up the thread from the phone device.  A separate thread processes the events.  I can provide log files or whatever would be useful, not sure if you want that yet.  I also upgraded my hi-phone desktop lite to the latest firmware: 5.03.17
Back to Top
 Post Reply Post Reply

Forum Jump Forum Permissions View Drop Down

This page was generated in 0.375 seconds.